0

Materials won't load

Anonymous 6 years ago 0
This discussion was imported from CodePlex

sion005 wrote at 2011-10-26 17:49:

Greetings, I'm using Helix in an application to view 3d models, however, when I import the model, it's all black, with no materials. I tried several models, including the ones used on the Studio example, but the result was the same. Probably I'm doing some newbie mistake, but i would appreciate some tips to solve this.

 Here is the code that I use to load the model:

 // Fields
private TerrainCreator tc;
private Model3D CurrentModel;
private ModelVisual3D render;


public MainWindow()
{
this.InitializeComponent();

this.render = new ModelVisual3D();

this.CurrentModel = ModelImporter.Load("C:\\Users\\Pedro\\Desktop\\Helix\\HelixToolkit-Examples\\StudioDemo\\Models\\Ferarri40.3ds");

this.render.Content = this.CurrentModel;
this.view.Add(render); // this is the HelixView3D

}


objo wrote at 2011-10-26 20:43:

hi Pedro! a simple question first: did you add lights to your scene? Helix toolkit has a couple of light visuals, and also a 'headlight' in the HelixViewport3D control.


sion005 wrote at 2011-10-31 15:49:

Problem solved. I didn't had any lights! Thanks a lot!