0

Beginners Question

Anonymous 6 years ago updated by anonymous 4 months ago 3
This discussion was imported from CodePlex

Patpop01 wrote at 2014-03-22 08:41:

Hi all,

I just downloaded and was trying my first program.

But I have some issues...

I have written following code
<Window x:Class="MainWindow"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:helix="http://helixtoolkit.codeplex.com"
    Title="Prova" Height="378" Width="605" 
    WindowStartupLocation="CenterScreen">
    <Grid>
        <helix:HelixView3D IsViewportHitTestVisible="True">
            <helix:HelixView3D.Camera>
                <PerspectiveCamera LookDirection="-10,-10,-10" Position="10,10,10" UpDirection="0,0,1"/>
            </helix:HelixView3D.Camera>
        </helix:HelixView3D>
    </Grid>
</Window>
But I am always getting errors stating :

__The name "HelixView3D" does not exist in the namespace "http://helixtoolkit.codeplex.com".__
__The tag 'HelixView3D' does not exist in XML namespace 'http://helixtoolkit.codeplex.com'.__
The type 'helix:HelixView3D' was not found. Verify that you are not missing an assembly reference and that all referenced assemblies have been built.
The attachable property 'Camera' was not found in type 'HelixView3D'.

In the project props I added a reference to HelixToolkit and alle HelixToolkit.wpf items.
I am using VS Express 2012 and have the latest Helix 3D Toolkit.

When I use the code of (Wiki Link: [discussion:459092] ) the code builds, but I still get the
__The name "HelixViewport3D" does not exist in the namespace "http://helixtoolkit.codeplex.com".__ error.

Any ideas?

Thx

Mrme wrote at 2014-03-25 10:27:

Hi , use this line instead :
xmlns:helix="clr-namespace:HelixToolkit.Wpf;assembly=HelixToolkit.Wpf"

Patpop01 wrote at 2014-03-26 06:43:

Hi Thanks for the response... But I did already tried that.

However I finally got it working...

First I tried the install the Nuget on VS2012 express... but that didn't work.
I downloaded the source files using the SVN link on the documentation/install page and tried to build, but I always got an error stating the helixtoolkit.csproj was not compatible with my current version.

So Uninstalled the VS2012 and installed the VS2013 express.
Still the same problem when trying to build myself...
But under VS2013 the Nuget worked. Since then I am enjoying this toolkit.

Now my code does not give me any warning or error.
Thx


tdiethe wrote at 2014-05-01 13:06:

FAQ page is empty??

objo wrote at 2014-05-05 14:57:

cache problem? The FAQ page should contain 3 questions.